PYSEC-2026-37
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dash-uploader 0.7.0a1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI dash-uploader
- Affected
- >= 0.1.0, < 0.7.0a1
- Fixed in
- 0.7.0a1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-37 lists affected ranges: PyPI dash-uploader >=0.1.0 <0.7.0a1 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-38361: 2.64% estimated exploitation activity in the next 30 days; percentile 85.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue in fohrloop dash-uploader v.0.1.0 through v.0.7.0a2 allows a remote attacker to execute arbitrary code via the dash_uploader/httprequesthandler.py, dash_uploader/upload.py in the Upload function and max_file_size parameter, dash_uploader/configure_upload.py components
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record PYSEC-2026-37
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-38361 Advisory: PYSEC-2026-37 IDs: CVE-2026-38361 Record: https://patchnext.com/advisories/cve-2026-38361 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dash-uploader 0.7.0a1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI dash-uploader: affected >= 0.1.0, < 0.7.0a1; fixed in 0.7.0a1 ## Suggested inspection (read-only) - `python -m pip show dash-uploader`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dash-uploader. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2026-37 (OSV record PYSEC-2026-37 lists affected ranges: PyPI dash-uploader >=0.1.0 <0.7.0a1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…