Fedify affected by resource exhaustion caused by unbounded redirect following during remote key/document resolution
CVE-2026-34148GHSA-gm9m-gwc4-hwgp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fedify/fedify 2.1.1, 2.0.8, 1.10.5, 1.9.6; @fedify/vocab-runtime 2.1.1, 2.0.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @fedify/fedify
- Affected
- < 1.9.6>= 1.10.0, < 1.10.5>= 2.0.0, < 2.0.8>= 2.1.0, <= 2.1.0
- Fixed in
- 1.10.5, 2.0.8, 2.1.1, 1.9.6
- Affected
- < 2.0.8>= 2.1.0, <= 2.1.0
- Fixed in
- 2.0.8, 2.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gm9m-gwc4-hwgp lists affected ranges: npm @fedify/fedify >=0 =1.10.0 =2.0.0 =2.1.0 =0 =2.1.0 <2.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gm9m-gwc4-hwgp lists affected ranges: npm @fedify/fedify >=0 =1.10.0 =2.0.0 =2.1.0 =0 =2.1.0 <=2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-34148: 0.57% estimated exploitation activity in the next 30 days; percentile 47.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary @fedify/fedify follows HTTP redirects recursively in its remote document loader and authenticated document loader without enforcing a maximum redirect count or visited-URL loop detection. An attacker who controls a remote ActivityPub key or actor URL can force a server using Fedify to make repeated outbound requests from a single inbound request, leading to resource consumption and denial of service. Details Fedify verifies ActivityPub HTTP signatures by fetching the remote keyId during request processing. The relevant flow is handleInboxInternal() - verifyRequest() - fetchKeyInternal() - document loader. In affected versions: - the generic document loader recursively follows 3xx responses by calling load() again on the Location header - the authenticated redirect path (doubleKnock()) also recursively follows redirects - neither path enforces a redirect cap or tracks visited URLs to detect self-referential redirect loops As a result, if an attacker-controlled keyId or actor…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gm9m-gwc4-hwgp
- Revision 1 · created ·
Published from osv record GHSA-gm9m-gwc4-hwgp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-34148 Advisory: Fedify affected by resource exhaustion caused by unbounded redirect following during remote key/document resolution IDs: CVE-2026-34148, GHSA-gm9m-gwc4-hwgp Record: https://patchnext.com/advisories/cve-2026-34148 (revision 2, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @fedify/fedify 2.1.1, 2.0.8, 1.10.5, 1.9.6; @fedify/vocab-runtime 2.1.1, 2.0.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @fedify/fedify: affected < 1.9.6; >= 1.10.0, < 1.10.5; >= 2.0.0, < 2.0.8; >= 2.1.0, <= 2.1.0; fixed in 1.10.5, 2.0.8, 2.1.1, 1.9.6 - npm @fedify/vocab-runtime: affected < 2.0.8; >= 2.1.0, <= 2.1.0; fixed in 2.0.8, 2.1.1 ## Suggested inspection (read-only) - `npm ls @fedify/fedify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @fedify/vocab-runtime --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @fedify/fedify, @fedify/vocab-runtime. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gm9m-gwc4-hwgp (OSV record GHSA-gm9m-gwc4-hwgp lists affected ranges: npm @fedify/fedify >=0 =1.10.0 =2.0.0 =2.1.0 =0 =2.1.0 <2.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-gm9m-gwc4-hwgp (GitHub-reviewed advisory GHSA-gm9m-gwc4-hwgp lists affected ranges: npm @fedify/fedify >=0 =1.10.0 =2.0.0 =2.1.0 =0 =2.1.0 <=2.1.0) Commands are suggestions: review each one before running it.
Loading voting…