simplesamlphp/xml-security: Missing AES-GCM Authentication Tag Validation on Encrypted Nodes Allows for Unauthorized Decryption
CVE-2026-32600GHSA-r353-4845-pr5p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (simplesamlphp/xml-security 2.3.1, 1.13.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist simplesamlphp/xml-security
- Affected
- >= 2.0.0, < 2.3.1< 1.13.9
- Fixed in
- 1.13.9, 2.3.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r353-4845-pr5p lists affected ranges: Packagist simplesamlphp/xml-security >=2.0.0 =0 <1.13.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-32600: 0.15% estimated exploitation activity in the next 30 days; percentile 4.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary XML nodes encrypted with either aes-128-gcm, aes-192-gcm, or aes-256-gcm lack validation of the authentication tag length. An attacker can use this to brute-force an authentication tag, recover the GHASH key, and decrypt the encrypted nodes. It also allows to forge arbitrary ciphertexts without knowing the encryption key. Details When decrypting with either aes-128-gcm, aes-192-gcm, or aes-256-gcm here, the $authTag is set from a substr(), but never has its length validated (it should be validated with something like strlen($authTag) == self::AUTHTAGLENGTH). For that reason, a shorter than expected data blob will allow for the $authTag to have as short a tag as only one byte (see PHP's documentation%20has%20been%20called.%20Otherwise%20the%20decryption%20may%20succeed%20if%20the%20given%20tag%20only%20matches%20the%20start%20of%20the%20proper%20tag.)). See this example: With a legit ciphertext in hand, this is enough to recover the GHASH key. With that key, any authenticated…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r353-4845-pr5p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32600 Advisory: simplesamlphp/xml-security: Missing AES-GCM Authentication Tag Validation on Encrypted Nodes Allows for Unauthorized Decryption IDs: CVE-2026-32600, GHSA-r353-4845-pr5p Record: https://patchnext.com/advisories/cve-2026-32600 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: simplesamlphp/xml-security 2.3.1, 1.13.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist simplesamlphp/xml-security: affected >= 2.0.0, < 2.3.1; < 1.13.9; fixed in 1.13.9, 2.3.1 ## Suggested inspection (read-only) - Packagist simplesamlphp/xml-security: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on simplesamlphp/xml-security. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r353-4845-pr5p (GitHub-reviewed advisory GHSA-r353-4845-pr5p lists affected ranges: Packagist simplesamlphp/xml-security >=2.0.0 =0 <1.13.9) Commands are suggestions: review each one before running it.
Loading voting…