Skip to content

← Actionable
High, CVSS 7.1amended

Flowise affected by Server-Side Request Forgery (SSRF) in HTTP Node Leading to Internal Network Access

CVE-2026-31829GHSA-fvcw-9w9r-pxc7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise-components 3.0.13; flowise 3.0.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-31829: 2.44% estimated exploitation activity in the next 30 days; percentile 84.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description: Flowise exposes an HTTP Node in AgentFlow and Chatflow that performs server-side HTTP requests using user-controlled URLs. By default, there are no restrictions on target hosts, including private/internal IP ranges (RFC 1918), localhost, or cloud metadata endpoints. This enables Server-Side Request Forgery (SSRF), allowing any user interacting with a publicly exposed chatflow to force the Flowise server to make requests to internal network resources that are inaccessible from the public internet. Impact includes: - Access to internal admin panels (e.g., internal company dashboards, Jenkins, Kubernetes API, etc.). - Retrieval of cloud provider metadata (e.g., AWS IMDSv1 at [http://169.254.169.254], GCP, Azure). - Port scanning and enumeration of internal services. - Potential lateral movement or privilege escalation in compromised environments. This vulnerability is particularly severe because: - Flowise instances are often deployed publicly without authentication…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fvcw-9w9r-pxc7

  2. Revision 1 · created ·

    Published from osv record GHSA-fvcw-9w9r-pxc7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-31829

Advisory: Flowise affected by Server-Side Request Forgery (SSRF) in HTTP Node Leading to Internal Network Access
IDs: CVE-2026-31829, GHSA-fvcw-9w9r-pxc7
Record: https://patchnext.com/advisories/cve-2026-31829 (revision 2, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise-components 3.0.13; flowise 3.0.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise-components: affected <= 3.0.12; fixed in 3.0.13
- npm flowise: affected <= 3.0.12; fixed in 3.0.13

## Suggested inspection (read-only)
- `npm ls flowise-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise-components, flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fvcw-9w9r-pxc7 (OSV record GHSA-fvcw-9w9r-pxc7 lists affected ranges: npm flowise >=0 =0 <3.0.13 (fixed))
- Verified: https://github.com/advisories/GHSA-fvcw-9w9r-pxc7 (GitHub-reviewed advisory GHSA-fvcw-9w9r-pxc7 lists affected ranges: npm flowise >=0 =0 <=3.0.12)

Commands are suggestions: review each one before running it.

Loading voting…