Yamux vulnerable to remote Panic via malformed WindowUpdate credit
CVE-2026-31814GHSA-4w32-2493-32g7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yamux 0.13.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io yamux
- Affected
- >= 0.13.0, < 0.13.9
- Fixed in
- 0.13.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4w32-2493-32g7 lists affected ranges: crates.io yamux >=0.13.0 <0.13.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-31814: 0.48% estimated exploitation activity in the next 30 days; percentile 41.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Sumary The Rust implementation of Yamux accepts WindowUpdate credit values from the remote peer and applies them to per-stream send-window state. A specially crafted WindowUpdate can cause arithmetic overflow in send-window accounting, which triggers a panic in the connection state machine. This is remotely reachable over a normal network connection and does not require authentication. Attack Scenario An attacker that can establish a Yamux session with a target node can crash the target by sending two validly encoded Yamux frames: 1. Open a stream (e.g. DATA + SYN) so the stream exists with initial send-window state (DEFAULTCREDIT). 2. Send a WindowUpdate on that stream with a very large credit value (e.g. 0xFFFF0000) such that adding credit to the current send-window overflows u32. Impact Remote unauthenticated denial of service. An attacker can repeatedly trigger panics by reconnecting and replaying the crafted frame sequence. Patches Users should upgrade to yamux v0.13.9 This…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4w32-2493-32g7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-31814 Advisory: Yamux vulnerable to remote Panic via malformed WindowUpdate credit IDs: CVE-2026-31814, GHSA-4w32-2493-32g7 Record: https://patchnext.com/advisories/cve-2026-31814 (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yamux 0.13.9. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io yamux: affected >= 0.13.0, < 0.13.9; fixed in 0.13.9 ## Suggested inspection (read-only) - crates.io yamux: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yamux. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4w32-2493-32g7 (GitHub-reviewed advisory GHSA-4w32-2493-32g7 lists affected ranges: crates.io yamux >=0.13.0 <0.13.9) Commands are suggestions: review each one before running it.
Loading voting…