Skip to content

← Actionable
Critical, CVSS 9.8

PYSEC-2026-119

CVE-2026-27960GHSA-6vvv-vmfr-xhrx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pycti 6.9.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pycti

    Affected
    >= 6.9.0, < 6.9.13
    Fixed in
    6.9.13

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-27960: 7.09% estimated exploitation activity in the next 30 days; percentile 94.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. In versions 6.6.0 through 6.9.12, there is a privilege escalation vulnerability that can be exploited by unauthenticated attackers to query the API as any existing user, including the default admin account. This issue has been fixed in version 6.9.13. As a workaround, the default admin can be disabled using the `APPADMINEXTERNALLY_MANAGED` configuration.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record PYSEC-2026-119

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27960

Advisory: PYSEC-2026-119
IDs: CVE-2026-27960, GHSA-6vvv-vmfr-xhrx
Record: https://patchnext.com/advisories/cve-2026-27960 (revision 1, source checked 24 Oct 2026, 04:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pycti 6.9.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pycti: affected >= 6.9.0, < 6.9.13; fixed in 6.9.13

## Suggested inspection (read-only)
- `python -m pip show pycti`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pycti.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/PYSEC-2026-119 (OSV record PYSEC-2026-119 lists affected ranges: PyPI pycti >=6.9.0 <6.9.13 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…