Skip to content

← Actionable
Low, CVSS 2.3

uTLS has a fingerprint vulnerability from missing padding extension for Chrome 120

CVE-2026-26995GHSA-rrxv-pmq9-x67r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/refraction-networking/utls 1.8.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

The padding extension was incorrectly removed in utls for the non-pq variant of Chrome 120 fingerprint. Chrome removed this extension only when sending pq keyshares. Only this fingerprint is affected since newer fingerprints have pq keyshares by default and older fingerprints have this extension. Affected symbols: HelloChrome120 Fix commit: 8fe0b08e9a0e7e2d08b268f451f2c79962e6acd0 Thanks to telegram @acgdaily for reporting this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rrxv-pmq9-x67r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26995

Advisory: uTLS has a fingerprint vulnerability from missing padding extension for Chrome 120
IDs: CVE-2026-26995, GHSA-rrxv-pmq9-x67r
Record: https://patchnext.com/advisories/cve-2026-26995 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/refraction-networking/utls 1.8.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/refraction-networking/utls: affected >= 1.6.0, < 1.8.2; fixed in 1.8.2

## Suggested inspection (read-only)
- Go github.com/refraction-networking/utls: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/refraction-networking/utls.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rrxv-pmq9-x67r (GitHub-reviewed advisory GHSA-rrxv-pmq9-x67r lists affected ranges: Go github.com/refraction-networking/utls >=1.6.0 <1.8.2)

Commands are suggestions: review each one before running it.

Loading voting…