Spinnaker clouddriver and orca URL validation bypass via underscores in hostnames
CVE-2026-25534GHSA-8r8j-gfhg-fw38
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.spinnaker.orca:orca-core 2025.4.1, 2025.3.1, 2025.2.4; io.spinnaker.clouddriver:clouddriver-artifacts 2025.4.1, 2025.3.1, 2025.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.spinnaker.orca:orca-core
- Affected
- >= 2025.3.0, < 2025.3.1>= 2025.4.0, < 2025.4.1>= 2025.1.6, < 2025.2.4
- Fixed in
- 2025.3.1, 2025.2.4, 2025.4.1
Maven io.spinnaker.clouddriver:clouddriver-artifacts
- Affected
- >= 2025.3.0, < 2025.3.1>= 2025.4.0, < 2025.4.1>= 2025.1.6, < 2025.2.4
- Fixed in
- 2025.3.1, 2025.2.4, 2025.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8r8j-gfhg-fw38 lists affected ranges: Maven io.spinnaker.clouddriver:clouddriver-artifacts >=2025.3.0 =2025.4.0 =2025.1.6 =2025.3.0 =2025.4.0 =2025.1.6 <2025.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L
- EPSS
- CVE-2026-25534: 0.26% estimated exploitation activity in the next 30 days; percentile 18.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Spinnaker updated URL Validation logic on user input to provide sanitation on user inputted URLs for clouddriver. However, they missed that Java URL objects do not correctly handle underscores on parsing. This led to a bypass of the previous CVE (CVE-2025-61916) through the use of carefully crafted URLs. Note, Spinnaker found this not just in that CVE, but in the existing URL validations in Orca fromUrl expression handling. This CVE impacts BOTH artifacts as a result. Patches This has been merged and will be available in versions 2025.4.1, 2025.3.1, 2025.2.4 and 2026.0.0. Workarounds You can disable the various artifacts on this system to work around these limits.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8r8j-gfhg-fw38
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25534 Advisory: Spinnaker clouddriver and orca URL validation bypass via underscores in hostnames IDs: CVE-2026-25534, GHSA-8r8j-gfhg-fw38 Record: https://patchnext.com/advisories/cve-2026-25534 (revision 1, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.spinnaker.orca:orca-core 2025.4.1, 2025.3.1, 2025.2.4; io.spinnaker.clouddriver:clouddriver-artifacts 2025.4.1, 2025.3.1, 2025.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.spinnaker.orca:orca-core: affected >= 2025.3.0, < 2025.3.1; >= 2025.4.0, < 2025.4.1; >= 2025.1.6, < 2025.2.4; fixed in 2025.3.1, 2025.2.4, 2025.4.1 - Maven io.spinnaker.clouddriver:clouddriver-artifacts: affected >= 2025.3.0, < 2025.3.1; >= 2025.4.0, < 2025.4.1; >= 2025.1.6, < 2025.2.4; fixed in 2025.3.1, 2025.2.4, 2025.4.1 ## Suggested inspection (read-only) - Maven io.spinnaker.orca:orca-core: check the installed version with your package manager. - Maven io.spinnaker.clouddriver:clouddriver-artifacts: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.spinnaker.orca:orca-core, io.spinnaker.clouddriver:clouddriver-artifacts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8r8j-gfhg-fw38 (GitHub-reviewed advisory GHSA-8r8j-gfhg-fw38 lists affected ranges: Maven io.spinnaker.clouddriver:clouddriver-artifacts >=2025.3.0 =2025.4.0 =2025.1.6 =2025.3.0 =2025.4.0 =2025.1.6 <2025.2.4) Commands are suggestions: review each one before running it.
Loading voting…