Skip to content

← Actionable
High, CVSS 8.1amended

Keycloak has authentication bypass via jwt algorithm confusion

CVE-2026-11800GHSA-j97h-3f8r-mrjr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.keycloak:keycloak-services 26.6.4; keycloak 26.6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-11800: 0.30% estimated exploitation activity in the next 30 days; percentile 22.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description A flaw was found in Keycloak. This JWT algorithm confusion vulnerability in the JWT Authorization Grant flow allows an attacker with valid client credentials to bypass signature verification. By forging an assertion, the attacker can create unauthorized access tokens. This enables the attacker to impersonate any federated user linked to the affected Identity Provider, leading to unauthorized access and potential privilege escalation.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record BIT-keycloak-2026-11800

  2. Revision 2 · amended ·

    Amended from osv record GHSA-j97h-3f8r-mrjr

  3. Revision 1 · created ·

    Published from ghsa record GHSA-j97h-3f8r-mrjr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-11800

Advisory: Keycloak has authentication bypass via jwt algorithm confusion
IDs: CVE-2026-11800, GHSA-j97h-3f8r-mrjr
Record: https://patchnext.com/advisories/cve-2026-11800 (revision 3, source checked 4 Nov 2026, 06:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.keycloak:keycloak-services 26.6.4; keycloak 26.6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.keycloak:keycloak-services: affected < 26.6.4; fixed in 26.6.4
- Bitnami keycloak: affected >= 26.6.0, < 26.6.4; fixed in 26.6.4

## Suggested inspection (read-only)
- Maven org.keycloak:keycloak-services: check the installed version with your package manager.
- Bitnami keycloak: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.keycloak:keycloak-services, keycloak.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j97h-3f8r-mrjr (GitHub-reviewed advisory GHSA-j97h-3f8r-mrjr lists affected ranges: Maven org.keycloak:keycloak-services >=0 <26.6.4)
- Verified: https://osv.dev/vulnerability/GHSA-j97h-3f8r-mrjr (OSV record GHSA-j97h-3f8r-mrjr lists affected ranges: Maven org.keycloak:keycloak-services >=0 <26.6.4 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-keycloak-2026-11800 (OSV record BIT-keycloak-2026-11800 lists affected ranges: Bitnami keycloak >=26.6.0 <26.6.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…