Langflow: OS command injection (RCE) via arbitrary command in MCP stdio server configuration
CVE-2026-105697GHSA-w794-rj3p-xv45
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow-base 0.10.3; lfx 1.10.3; langflow 1.10.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langflow-base
- Affected
- >= 0.1.2, < 0.10.3
- Fixed in
- 0.10.3
PyPI lfx
- Affected
- < 1.10.3
- Fixed in
- 1.10.3
PyPI langflow
- Affected
- >= 1.1.2, < 1.10.3
- Fixed in
- 1.10.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w794-rj3p-xv45 lists affected ranges: PyPI langflow >=1.1.2 =0.1.2 =0 <1.10.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w794-rj3p-xv45 lists affected ranges: PyPI langflow >=1.1.2 =0.1.2 =0 <1.10.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-105697: 0.95% estimated exploitation activity in the next 30 days; percentile 61.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Before Langflow 1.10.3, the MCP stdio transport launched whatever command / args a user put in an MCP server configuration, with no allowlist and (before 1.10.3) wrapped in bash -c "exec {command} ...". Any user able to reach the MCP server settings ("Settings → MCP Servers → Add MCP Server", POST/PATCH /api/v2/mcp/servers/{servername}) or to build a flow with the MCP Tools component could add a "server" whose command is an arbitrary OS command (touch, rm -rf, a reverse shell, ...). The command runs on the Langflow host as the Langflow process user as soon as Langflow tries to connect to the server (listing servers, loading tools, running the flow) — even when the UI then reports that the stdio server failed to start. With the default LANGFLOWAUTOLOGIN=true, GET /api/v1/autologin hands out a token without credentials, so on an exposed instance running the default configuration this is reachable without an account. AUTOLOGIN is documented as a development-only setting; with it…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w794-rj3p-xv45
- Revision 2 · amended ·
Amended from osv record GHSA-w794-rj3p-xv45
- Revision 1 · created ·
Published from ghsa record GHSA-w794-rj3p-xv45
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-105697 Advisory: Langflow: OS command injection (RCE) via arbitrary command in MCP stdio server configuration IDs: CVE-2026-105697, GHSA-w794-rj3p-xv45 Record: https://patchnext.com/advisories/cve-2026-105697 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langflow-base 0.10.3; lfx 1.10.3; langflow 1.10.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langflow-base: affected >= 0.1.2, < 0.10.3; fixed in 0.10.3 - PyPI lfx: affected < 1.10.3; fixed in 1.10.3 - PyPI langflow: affected >= 1.1.2, < 1.10.3; fixed in 1.10.3 ## Suggested inspection (read-only) - `python -m pip show langflow-base`: prints the installed version. Run with the environment that serves production active. - `python -m pip show lfx`: prints the installed version. Run with the environment that serves production active. - `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langflow-base, lfx, langflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w794-rj3p-xv45 (GitHub-reviewed advisory GHSA-w794-rj3p-xv45 lists affected ranges: PyPI langflow >=1.1.2 =0.1.2 =0 <1.10.3) - Verified: https://osv.dev/vulnerability/GHSA-w794-rj3p-xv45 (OSV record GHSA-w794-rj3p-xv45 lists affected ranges: PyPI langflow >=1.1.2 =0.1.2 =0 <1.10.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…