Skip to content

← Actionable
Medium, CVSS 6.5

Keycloak Privilege Escalation Vulnerability in Admin Console (FGAPv2 Enabled)

CVE-2025-7784GHSA-27gp-8389-hm4w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.keycloak:keycloak-services 26.2.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2025-7784: 0.45% estimated exploitation activity in the next 30 days; percentile 39.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A Privilege Escalation vulnerability was identified in the Keycloak identity and access management solution, specifically when FGAPv2 is enabled in version 26.2.x. The flaw lies in the admin permission enforcement logic, where a user with manage-users privileges can self-assign realm-admin rights. The escalation occurs due to missing privilege boundary checks in role mapping operations via the admin REST interface. A malicious administrator with limited permissions can exploit this by editing their own user roles, gaining unauthorized full access to realm configuration and user data. This issue has been fixed in versions 26.2.6, and 26.3.0.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-27gp-8389-hm4w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-7784

Advisory: Keycloak Privilege Escalation Vulnerability in Admin Console (FGAPv2 Enabled)
IDs: CVE-2025-7784, GHSA-27gp-8389-hm4w
Record: https://patchnext.com/advisories/cve-2025-7784 (revision 1, source checked 26 Oct 2026, 16:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.keycloak:keycloak-services 26.2.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.keycloak:keycloak-services: affected >= 26.2.0, < 26.2.6; fixed in 26.2.6

## Suggested inspection (read-only)
- Maven org.keycloak:keycloak-services: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.keycloak:keycloak-services.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-27gp-8389-hm4w (GitHub-reviewed advisory GHSA-27gp-8389-hm4w lists affected ranges: Maven org.keycloak:keycloak-services >=26.2.0 <26.2.6)

Commands are suggestions: review each one before running it.

Loading voting…