auth0/node-jws Improperly Verifies HMAC Signature
CVE-2025-65945GHSA-869p-cjfg-cm3x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jws 4.0.1, 3.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm jws
- Affected
- < 3.2.3>= 4.0.0, <= 4.0.0
- Fixed in
- 3.2.3, 4.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-869p-cjfg-cm3x lists affected ranges: npm jws >=0 =4.0.0 <4.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-869p-cjfg-cm3x lists affected ranges: npm jws >=0 =4.0.0 <=4.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2025-65945: 0.21% estimated exploitation activity in the next 30 days; percentile 12.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview An improper signature verification vulnerability exists when using auth0/node-jws with the HS256 algorithm under specific conditions. Am I Affected? You are affected by this vulnerability if you meet all of the following preconditions: 1. Application uses the auth0/node-jws implementation of JSON Web Signatures, versions <=3.2.2 || 4.0.0 2. Application uses the jws.createVerify() function for HMAC algorithms 3. Application uses user-provided data from the JSON Web Signature Protected Header or Payload in the HMAC secret lookup routines You are NOT affected by this vulnerability if you meet any of the following preconditions: 1. Application uses the jws.verify() interface (note: auth0/node-jsonwebtoken users fall into this category and are therefore NOT affected by this vulnerability) 2. Application uses only asymmetric algorithms (e.g. RS256) 3. Application doesn’t use user-provided data from the JSON Web Signature Protected Header or Payload in the HMAC secret lookup…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-869p-cjfg-cm3x
- Revision 1 · created ·
Published from osv record GHSA-869p-cjfg-cm3x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-65945 Advisory: auth0/node-jws Improperly Verifies HMAC Signature IDs: CVE-2025-65945, GHSA-869p-cjfg-cm3x Record: https://patchnext.com/advisories/cve-2025-65945 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jws 4.0.1, 3.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm jws: affected < 3.2.3; >= 4.0.0, <= 4.0.0; fixed in 3.2.3, 4.0.1 ## Suggested inspection (read-only) - `npm ls jws --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jws. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-869p-cjfg-cm3x (OSV record GHSA-869p-cjfg-cm3x lists affected ranges: npm jws >=0 =4.0.0 <4.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-869p-cjfg-cm3x (GitHub-reviewed advisory GHSA-869p-cjfg-cm3x lists affected ranges: npm jws >=0 =4.0.0 <=4.0.0) Commands are suggestions: review each one before running it.
Loading voting…