Skip to content

← Actionable
Critical, CVSS 10.0amended

md-to-pdf vulnerable to arbitrary JavaScript code execution when parsing front matter

CVE-2025-65108GHSA-547r-qmjm-8hvw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (md-to-pdf 5.2.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-65108: 0.96% estimated exploitation activity in the next 30 days; percentile 61.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Markdown front-matter block that contains JavaScript delimiter causes the JS engine in gray-matter library to execute arbitrary code in the Markdown to PDF converter process of md-to-pdf library, resulting in remote code execution. Details md-to-pdf uses the gray-matter library to parse front-matter. Gray-matter exposes a JavaScript engine that, when enabled or triggered by certain front-matter delimiters (e.g. ---js or ---javascript), will evaluate the front-matter contents as JavaScript. If user-supplied Markdown is fed to md-to-pdf and the front-matter contains malicious JS, the converter process will execute that code. PoC Running the PoC on Windows launches the calculator application, demonstrating arbitrary code execution. Impact - Remote code execution in the process that performs Markdown-PDF conversion. - If the converter is run in a web app or cloud service, an attacker uploading malicious Markdown can execute arbitrary commands on the

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-547r-qmjm-8hvw

  2. Revision 2 · amended ·

    Amended from osv record GHSA-547r-qmjm-8hvw

  3. Revision 1 · created ·

    Published from ghsa record GHSA-547r-qmjm-8hvw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-65108

Advisory: md-to-pdf vulnerable to arbitrary JavaScript code execution when parsing front matter
IDs: CVE-2025-65108, GHSA-547r-qmjm-8hvw
Record: https://patchnext.com/advisories/cve-2025-65108 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: md-to-pdf 5.2.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm md-to-pdf: affected < 5.2.5; fixed in 5.2.5

## Suggested inspection (read-only)
- `npm ls md-to-pdf --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on md-to-pdf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-547r-qmjm-8hvw (GitHub-reviewed advisory GHSA-547r-qmjm-8hvw lists affected ranges: npm md-to-pdf >=0 <5.2.5)
- Verified: https://osv.dev/vulnerability/GHSA-547r-qmjm-8hvw (OSV record GHSA-547r-qmjm-8hvw lists affected ranges: npm md-to-pdf >=0 <5.2.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…