Spinnaker vulnerable to SSRF due to improper restrictions on http from user input
CVE-2025-61916GHSA-vrjc-q2fh-6x9h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.spinnaker.clouddriver:clouddriver-artifacts 2025.2.3, 2025.1.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.spinnaker.clouddriver:clouddriver-artifacts
- Affected
- < 2025.1.6>= 2025.2.0, < 2025.2.3
- Fixed in
- 2025.2.3, 2025.1.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vrjc-q2fh-6x9h lists affected ranges: Maven io.spinnaker.clouddriver:clouddriver-artifacts >=0 =2025.2.0 <2025.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.9 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L
- EPSS
- CVE-2025-61916: 0.17% estimated exploitation activity in the next 30 days; percentile 6.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The primary impact is allowing users to fetch data from a remote URL. This data can be then injected into Spinnaker pipelines via helm or other methods to extract things LIKE idmsv1 authentication data. This ALSO includes calling INTERNAL Spinnaker API's via a get and similar endpoints. Further, depending upon the artifact configuration, auth data may be exposed to arbitrary endpoints (e.g. GitHub auth headers) leading to credentials exposure. To trigger this, a Spinnaker installation MUST have: An artifact enabled that allows user input. This includes GitHub file artifacts, BitBucket, GitLab, HTTP artifacts and similar artifact providers. JUST enabling the http artifact provider will add a "no-auth" http provider that could be used to extract link local data (e.g. AWS Metadata information). A system that can consume the output of these artifacts. E.g. Rosco helm can use this to fetch values data. K8s account manifests if the API returns JSON can be used to inject that data…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vrjc-q2fh-6x9h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-61916 Advisory: Spinnaker vulnerable to SSRF due to improper restrictions on http from user input IDs: CVE-2025-61916, GHSA-vrjc-q2fh-6x9h Record: https://patchnext.com/advisories/cve-2025-61916 (revision 1, source checked 26 Oct 2026, 16:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.spinnaker.clouddriver:clouddriver-artifacts 2025.2.3, 2025.1.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.spinnaker.clouddriver:clouddriver-artifacts: affected < 2025.1.6; >= 2025.2.0, < 2025.2.3; fixed in 2025.2.3, 2025.1.6 ## Suggested inspection (read-only) - Maven io.spinnaker.clouddriver:clouddriver-artifacts: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.spinnaker.clouddriver:clouddriver-artifacts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vrjc-q2fh-6x9h (GitHub-reviewed advisory GHSA-vrjc-q2fh-6x9h lists affected ranges: Maven io.spinnaker.clouddriver:clouddriver-artifacts >=0 =2025.2.0 <2025.2.3) Commands are suggestions: review each one before running it.
Loading voting…