Skip to content

← Actionable
Critical, CVSS 9.3amended

Modular Max Serve has Unsafe Deserialization vulnerability

CVE-2025-60455GHSA-7xcv-9j6c-2fmc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (modular 25.6.0; max 25.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI modular

    Affected
    < 25.6.0
    Fixed in
    25.6.0
  • PyPI max

    Affected
    < 25.6.0
    Fixed in
    25.6.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-60455: 0.33% estimated exploitation activity in the next 30 days; percentile 26.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unsafe Deserialization vulnerability in Modular Max Serve before 25.6, specifically when the "--experimental-enable-kvcache-agent" feature is used allowing attackers to execute arbitrary code.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from ghsa record GHSA-7xcv-9j6c-2fmc

  2. Revision 4 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 3 · amended ·

    Amended from osv record PYSEC-2025-253

  4. Revision 2 · amended ·

    Amended from osv record GHSA-7xcv-9j6c-2fmc

  5. Revision 1 · created ·

    Published from ghsa record GHSA-7xcv-9j6c-2fmc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-60455

Advisory: Modular Max Serve has Unsafe Deserialization vulnerability
IDs: CVE-2025-60455, GHSA-7xcv-9j6c-2fmc
Record: https://patchnext.com/advisories/cve-2025-60455 (revision 5, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: modular 25.6.0; max 25.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI modular: affected < 25.6.0; fixed in 25.6.0
- PyPI max: affected < 25.6.0; fixed in 25.6.0

## Suggested inspection (read-only)
- `python -m pip show modular`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show max`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on modular, max.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7xcv-9j6c-2fmc (GitHub-reviewed advisory GHSA-7xcv-9j6c-2fmc lists affected ranges: PyPI modular >=0 <25.6.0)
- Verified: https://osv.dev/vulnerability/GHSA-7xcv-9j6c-2fmc (OSV record GHSA-7xcv-9j6c-2fmc lists affected ranges: PyPI modular >=0 <25.6.0 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2025-253 (OSV record PYSEC-2025-253 lists affected ranges: PyPI max >=0 <25.6.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…