Skip to content

← Actionable
Medium, CVSS 5.3

Omni is Vulnerable to DoS via Empty Create/Update Resource Requests

CVE-2025-59836GHSA-4p3p-cr38-v5xp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/siderolabs/omni 1.1.5, 1.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2025-59836: 0.58% estimated exploitation activity in the next 30 days; percentile 47.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A nil pointer dereference vulnerability in the Omni Resource Service allows unauthenticated users to cause a server panic and denial of service by sending empty create/update resource requests through the API endpoints. Details The vulnerability exists in the isSensitiveSpec function which calls grpcomni.CreateResource without checking if the resource's metadata field is nil. When a resource is created with an empty Metadata field, the CreateResource function attempts to access resource.Metadata.Version causing a segmentation fault. Vulnerable Code The isSensitiveSpec function in /src/internal/backend/server.go: The CreateResource function expects resource.Metadata to be non-nil: The UpdateResource function has the same issue - it also calls CreateResource internally and expects resource.Metadata to be non-nil: Affected Endpoints - resourceServerCreate - Create Resource API endpoint - resourceServerUpdate - Update Resource API endpoint Both endpoints call isSensitiveSpec…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4p3p-cr38-v5xp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59836

Advisory: Omni is Vulnerable to DoS via Empty Create/Update Resource Requests
IDs: CVE-2025-59836, GHSA-4p3p-cr38-v5xp
Record: https://patchnext.com/advisories/cve-2025-59836 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/siderolabs/omni 1.1.5, 1.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/siderolabs/omni: affected >= 1.1.0-beta.0, <= 1.1.4; <= 1.0.1; fixed in 1.1.5, 1.0.2

## Suggested inspection (read-only)
- Go github.com/siderolabs/omni: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/siderolabs/omni.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4p3p-cr38-v5xp (GitHub-reviewed advisory GHSA-4p3p-cr38-v5xp lists affected ranges: Go github.com/siderolabs/omni >=1.1.0-beta.0 =0 <=1.0.1)

Commands are suggestions: review each one before running it.

Loading voting…