PyInstaller has local privilege escalation vulnerability
CVE-2025-59042GHSA-p2xp-xx3r-mffc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyinstaller 6.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pyinstaller
- Affected
- < 6.0.0
- Fixed in
- 6.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p2xp-xx3r-mffc lists affected ranges: PyPI pyinstaller >=0 <6.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p2xp-xx3r-mffc lists affected ranges: PyPI pyinstaller >=0 <6.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.0 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-59042: 0.13% estimated exploitation activity in the next 30 days; percentile 2.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Due to a special entry being appended to sys.path during the bootstrap process of a PyInstaller-frozen application, and due to the bootstrap script attempting to load an optional module for bytecode decryption while this entry is still present in sys.path, an application built with PyInstaller < 6.0.0 may be tricked by an unprivileged attacker into executing arbitrary python code when all of the following conditions are met: 1. Application is built with PyInstaller < 6.0.0; both onedir and onefile mode are affected. 2. Optional bytecode encryption code feature was not enabled during the application build. 3. The attacker can create files/directories in the same directory where the executable is located. 4. The filesystem supports creation of files/directories that contain ? in their name (i.e., non-Windows systems). 5. The attacker is able to determine the offset at which the PYZ archive is embedded in the executable. The attacker can create a directory (or a zip archive) next…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-p2xp-xx3r-mffc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-p2xp-xx3r-mffc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59042 Advisory: PyInstaller has local privilege escalation vulnerability IDs: CVE-2025-59042, GHSA-p2xp-xx3r-mffc Record: https://patchnext.com/advisories/cve-2025-59042 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pyinstaller 6.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pyinstaller: affected < 6.0.0; fixed in 6.0.0 ## Suggested inspection (read-only) - `python -m pip show pyinstaller`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pyinstaller. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p2xp-xx3r-mffc (OSV record GHSA-p2xp-xx3r-mffc lists affected ranges: PyPI pyinstaller >=0 <6.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-p2xp-xx3r-mffc (GitHub-reviewed advisory GHSA-p2xp-xx3r-mffc lists affected ranges: PyPI pyinstaller >=0 <6.0.0) Commands are suggestions: review each one before running it.
Loading voting…