OpenPGP.js's message signature verification can be spoofed
CVE-2025-47934GHSA-8qff-qr5q-5pr8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openpgp 6.1.1, 5.11.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openpgp
- Affected
- >= 5.0.1, <= 5.11.2>= 6.0.0-alpha.0, <= 6.1.0
- Fixed in
- 5.11.3, 6.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8qff-qr5q-5pr8 lists affected ranges: npm openpgp >=5.0.1 =6.0.0-alpha.0 <6.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8qff-qr5q-5pr8 lists affected ranges: npm openpgp >=5.0.1 =6.0.0-alpha.0 <=6.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-47934: 0.65% estimated exploitation activity in the next 30 days; percentile 50.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A maliciously modified message can be passed to either openpgp.verify or openpgp.decrypt, causing these functions to return a valid signature verification result while returning data that was not actually signed. This flaw allows signature verifications of inline (non-detached) signed messages (using openpgp.verify) and signed-and-encrypted messages (using openpgp.decrypt with verificationKeys) to be spoofed, since both functions return extracted data that may not match the data that was originally signed. Detached signature verifications are not affected, as no signed data is returned in that case. In order to spoof a message, the attacker needs a single valid message signature (inline or detached) as well as the plaintext data that was legitimately signed, and can then construct an inline-signed message or signed-and-encrypted message with any data of the attacker's choice, which will appear as legitimately signed by affected versions of OpenPGP.js. In other words. any…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8qff-qr5q-5pr8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8qff-qr5q-5pr8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-47934 Advisory: OpenPGP.js's message signature verification can be spoofed IDs: CVE-2025-47934, GHSA-8qff-qr5q-5pr8 Record: https://patchnext.com/advisories/cve-2025-47934 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openpgp 6.1.1, 5.11.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openpgp: affected >= 5.0.1, <= 5.11.2; >= 6.0.0-alpha.0, <= 6.1.0; fixed in 5.11.3, 6.1.1 ## Suggested inspection (read-only) - `npm ls openpgp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openpgp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8qff-qr5q-5pr8 (OSV record GHSA-8qff-qr5q-5pr8 lists affected ranges: npm openpgp >=5.0.1 =6.0.0-alpha.0 <6.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-8qff-qr5q-5pr8 (GitHub-reviewed advisory GHSA-8qff-qr5q-5pr8 lists affected ranges: npm openpgp >=5.0.1 =6.0.0-alpha.0 <=6.1.0) Commands are suggestions: review each one before running it.
Loading voting…