Skip to content

← Actionable
Medium, CVSS 4.8

Miniflux Media Proxy vulnerable to Stored Cross-site Scripting due to improper Content-Security-Policy configuration

CVE-2025-31483GHSA-cq88-842x-2jhp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (miniflux.app/v2 2.2.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2025-31483: 0.43% estimated exploitation activity in the next 30 days; percentile 36.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Due to a weak Content Security Policy on the /proxy/ route, an attacker can bypass the CSP of the media proxy and execute cross-site scripting when opening external images in a new tab/window. Impact A malicious feed added to Miniflux can execute arbitrary JavaScript in the user's browser when opening external resources, such as proxified images, in a new tab or window. Mitigation The CSP for the media proxy has been changed from default-src 'self' to default-src 'none'; form-action 'none'; sandbox;. Upgrade to Miniflux = 2.2.7 Credit RyotaK (GMO Flatt Security Inc.) with takumi-san.ai

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cq88-842x-2jhp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-31483

Advisory: Miniflux Media Proxy vulnerable to Stored Cross-site Scripting due to improper Content-Security-Policy configuration
IDs: CVE-2025-31483, GHSA-cq88-842x-2jhp
Record: https://patchnext.com/advisories/cve-2025-31483 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: miniflux.app/v2 2.2.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go miniflux.app/v2: affected < 2.2.7; fixed in 2.2.7

## Suggested inspection (read-only)
- Go miniflux.app/v2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on miniflux.app/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cq88-842x-2jhp (GitHub-reviewed advisory GHSA-cq88-842x-2jhp lists affected ranges: Go miniflux.app/v2 >=0 <2.2.7)

Commands are suggestions: review each one before running it.

Loading voting…