Additional TCA Allows Cross-Site Scripting (XSS)
CVE-2025-30083GHSA-rrh3-cgmx-w62f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (codingms/additional-tca 1.16.9, 1.15.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist codingms/additional-tca
- Affected
- >= 1.16.0, < 1.16.9>= 1.7.0, < 1.15.17
- Fixed in
- 1.15.17, 1.16.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rrh3-cgmx-w62f lists affected ranges: Packagist codingms/additional-tca >=1.16.0 =1.7.0 <1.15.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L/E:F/RL:O/RC:C
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
A cross-site scripting (XSS) vulnerability has been discovered in the Additional TCA extension. This vulnerabily is exploitable by a logged in backend user utilizing the TYPO3 backend user interface. This user can create output in the HTML context by exploiting improperly encoded user input. Updates 1.15.17 and 1.16.9 are available for download.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rrh3-cgmx-w62f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-30083 Advisory: Additional TCA Allows Cross-Site Scripting (XSS) IDs: CVE-2025-30083, GHSA-rrh3-cgmx-w62f Record: https://patchnext.com/advisories/cve-2025-30083 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: codingms/additional-tca 1.16.9, 1.15.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist codingms/additional-tca: affected >= 1.16.0, < 1.16.9; >= 1.7.0, < 1.15.17; fixed in 1.15.17, 1.16.9 ## Suggested inspection (read-only) - Packagist codingms/additional-tca: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on codingms/additional-tca. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rrh3-cgmx-w62f (GitHub-reviewed advisory GHSA-rrh3-cgmx-w62f lists affected ranges: Packagist codingms/additional-tca >=1.16.0 =1.7.0 <1.15.17) Commands are suggestions: review each one before running it.
Loading voting…