Skip to content

← Actionable
Critical, CVSS 9.3amended

xml-crypto Vulnerable to XML Signature Verification Bypass via DigestValue Comment

CVE-2025-29775GHSA-x3m8-899r-f7c3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (xml-crypto 6.0.1, 3.2.1, 2.1.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm xml-crypto

    Affected
    >= 4.0.0, < 6.0.1>= 3.0.0, < 3.2.1< 2.1.6
    Fixed in
    3.2.1, 6.0.1, 2.1.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-29775: 10.14% estimated exploitation activity in the next 30 days; percentile 95.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker may be able to exploit this vulnerability to bypass authentication or authorization mechanisms in systems that rely on xml-crypto for verifying signed XML documents. The vulnerability allows an attacker to modify a valid signed XML message in a way that still passes signature verification checks. For example, it could be used to alter critical identity or access control attributes, enabling an attacker to escalate privileges or impersonate another user. Patches All versions <= 6.0.0 are affected. Please upgrade to version 6.0.1. If you are still using v2.x or v3.x please upgrade to the associated patch version. Indicators of Compromise When logging XML payloads, check for the following indicators. If the payload includes encrypted elements, ensure you analyze the decrypted version for a complete assessment. (If encryption is not used, analyze the original XML document directly). This applies to various XML-based authentication and authorization flows, such as SAML…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x3m8-899r-f7c3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-x3m8-899r-f7c3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-29775

Advisory: xml-crypto Vulnerable to XML Signature Verification Bypass via DigestValue Comment
IDs: CVE-2025-29775, GHSA-x3m8-899r-f7c3
Record: https://patchnext.com/advisories/cve-2025-29775 (revision 3, source checked 26 Oct 2026, 12:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: xml-crypto 6.0.1, 3.2.1, 2.1.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm xml-crypto: affected >= 4.0.0, < 6.0.1; >= 3.0.0, < 3.2.1; < 2.1.6; fixed in 3.2.1, 6.0.1, 2.1.6

## Suggested inspection (read-only)
- `npm ls xml-crypto --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on xml-crypto.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x3m8-899r-f7c3 (OSV record GHSA-x3m8-899r-f7c3 lists affected ranges: npm xml-crypto >=4.0.0 =3.0.0 =0 <2.1.6 (fixed))
- Verified: https://github.com/advisories/GHSA-x3m8-899r-f7c3 (GitHub-reviewed advisory GHSA-x3m8-899r-f7c3 lists affected ranges: npm xml-crypto >=4.0.0 =3.0.0 =0 <2.1.6)

Commands are suggestions: review each one before running it.

Loading voting…