Spacy-LLM Server-Side Template Injection (SSTI) vulnerability
CVE-2025-25362GHSA-793v-gxfp-9q9h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (spacy-llm 0.7.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI spacy-llm
- Affected
- <= 0.7.2
- Fixed in
- 0.7.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-793v-gxfp-9q9h lists affected ranges: PyPI spacy-llm >=0 <0.7.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-793v-gxfp-9q9h lists affected ranges: PyPI spacy-llm >=0 <=0.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-25362: 0.80% estimated exploitation activity in the next 30 days; percentile 56.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Server-Side Template Injection (SSTI) vulnerability in Spacy-LLM v0.7.2 allows attackers to execute arbitrary code via injecting a crafted payload into the template field.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-793v-gxfp-9q9h
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-793v-gxfp-9q9h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-25362 Advisory: Spacy-LLM Server-Side Template Injection (SSTI) vulnerability IDs: CVE-2025-25362, GHSA-793v-gxfp-9q9h Record: https://patchnext.com/advisories/cve-2025-25362 (revision 3, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: spacy-llm 0.7.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI spacy-llm: affected <= 0.7.2; fixed in 0.7.3 ## Suggested inspection (read-only) - `python -m pip show spacy-llm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on spacy-llm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-793v-gxfp-9q9h (OSV record GHSA-793v-gxfp-9q9h lists affected ranges: PyPI spacy-llm >=0 <0.7.3 (fixed)) - Verified: https://github.com/advisories/GHSA-793v-gxfp-9q9h (GitHub-reviewed advisory GHSA-793v-gxfp-9q9h lists affected ranges: PyPI spacy-llm >=0 <=0.7.2) Commands are suggestions: review each one before running it.
Loading voting…