TYPO3 Modules Extension has Improper Authentication vulnerability
CVE-2025-12998GHSA-49qv-h8pm-73pf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (codingms/modules 7.5.5, 6.4.2, 5.7.4, 4.3.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist codingms/modules
- Affected
- < 4.3.11>= 5.0.0, < 5.7.4>= 7.0.0, < 7.5.5>= 6.0.0, < 6.4.2
- Fixed in
- 6.4.2, 4.3.11, 5.7.4, 7.5.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-49qv-h8pm-73pf lists affected ranges: Packagist codingms/modules >=0 =5.0.0 =7.0.0 =6.0.0 <6.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-12998: 0.36% estimated exploitation activity in the next 30 days; percentile 29.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Authentication vulnerability in TYPO3 Extension "Modules" codingms/modules. This issue affects Extension "Modules": before 4.3.11, from 5.0.0 before 5.7.4, from 6.0.0 before 6.4.2, from 7.0.0 before 7.5.5.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-49qv-h8pm-73pf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-12998 Advisory: TYPO3 Modules Extension has Improper Authentication vulnerability IDs: CVE-2025-12998, GHSA-49qv-h8pm-73pf Record: https://patchnext.com/advisories/cve-2025-12998 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: codingms/modules 7.5.5, 6.4.2, 5.7.4, 4.3.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist codingms/modules: affected < 4.3.11; >= 5.0.0, < 5.7.4; >= 7.0.0, < 7.5.5; >= 6.0.0, < 6.4.2; fixed in 6.4.2, 4.3.11, 5.7.4, 7.5.5 ## Suggested inspection (read-only) - Packagist codingms/modules: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on codingms/modules. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-49qv-h8pm-73pf (GitHub-reviewed advisory GHSA-49qv-h8pm-73pf lists affected ranges: Packagist codingms/modules >=0 =5.0.0 =7.0.0 =6.0.0 <6.4.2) Commands are suggestions: review each one before running it.
Loading voting…