Drupal Simple multi step form allows Cross-Site Scripting
CVE-2025-12761GHSA-gg35-374m-9ph8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/simple_multistep 2.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/simple_multistep
- Affected
- < 2.0.0
- Fixed in
- 2.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gg35-374m-9ph8 lists affected ranges: Packagist drupal/simple_multistep >=0 <2.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U · score source
- EPSS
- CVE-2025-12761: 0.19% estimated exploitation activity in the next 30 days; percentile 8.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Simple multi step form allows Cross-Site Scripting (XSS).This issue affects Simple multi step form: from 0.0.0 before 2.0.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gg35-374m-9ph8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-12761 Advisory: Drupal Simple multi step form allows Cross-Site Scripting IDs: CVE-2025-12761, GHSA-gg35-374m-9ph8 Record: https://patchnext.com/advisories/cve-2025-12761 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/simple_multistep 2.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/simple_multistep: affected < 2.0.0; fixed in 2.0.0 ## Suggested inspection (read-only) - Packagist drupal/simple_multistep: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/simple_multistep. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gg35-374m-9ph8 (GitHub-reviewed advisory GHSA-gg35-374m-9ph8 lists affected ranges: Packagist drupal/simple_multistep >=0 <2.0.0) Commands are suggestions: review each one before running it.
Loading voting…