Drupal Simple OAuth (OAuth2) & OpenID Connect allows Authentication Bypass
CVE-2025-12466GHSA-jqmq-fpwv-p925
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/simple_oauth 6.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/simple_oauth
- Affected
- >= 6.0.0, < 6.0.7
- Fixed in
- 6.0.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jqmq-fpwv-p925 lists affected ranges: Packagist drupal/simple_oauth >=6.0.0 <6.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2025-12466: 0.36% estimated exploitation activity in the next 30 days; percentile 29.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Authentication Bypass Using an Alternate Path or Channel vulnerability in Drupal Simple OAuth (OAuth2) & OpenID Connect allows Authentication Bypass. This issue affects Simple OAuth (OAuth2) & OpenID Connect: from 6.0.0 before 6.0.7.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jqmq-fpwv-p925
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-12466 Advisory: Drupal Simple OAuth (OAuth2) & OpenID Connect allows Authentication Bypass IDs: CVE-2025-12466, GHSA-jqmq-fpwv-p925 Record: https://patchnext.com/advisories/cve-2025-12466 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/simple_oauth 6.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/simple_oauth: affected >= 6.0.0, < 6.0.7; fixed in 6.0.7 ## Suggested inspection (read-only) - Packagist drupal/simple_oauth: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/simple_oauth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jqmq-fpwv-p925 (GitHub-reviewed advisory GHSA-jqmq-fpwv-p925 lists affected ranges: Packagist drupal/simple_oauth >=6.0.0 <6.0.7) Commands are suggestions: review each one before running it.
Loading voting…