Skip to content

← Actionable
Medium, CVSS 6.0

Keycloak vulnerable to session takeovers due to reuse of session identifiers

CVE-2025-12390GHSA-rg35-5v25-mqvp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.keycloak:keycloak-services 26.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.0 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2025-12390: 0.14% estimated exploitation activity in the next 30 days; percentile 3.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in Keycloak. In Keycloak where a user can accidentally get access to another user's session if both use the same device and browser. This happens because Keycloak sometimes reuses session identifiers and doesn’t clean up properly during logout when browser cookies are missing. As a result, one user may receive tokens that belong to another user.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rg35-5v25-mqvp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-12390

Advisory: Keycloak vulnerable to session takeovers due to reuse of session identifiers
IDs: CVE-2025-12390, GHSA-rg35-5v25-mqvp
Record: https://patchnext.com/advisories/cve-2025-12390 (revision 1, source checked 26 Oct 2026, 16:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.keycloak:keycloak-services 26.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.keycloak:keycloak-services: affected < 26.0.0; fixed in 26.0.0

## Suggested inspection (read-only)
- Maven org.keycloak:keycloak-services: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.keycloak:keycloak-services.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rg35-5v25-mqvp (GitHub-reviewed advisory GHSA-rg35-5v25-mqvp lists affected ranges: Maven org.keycloak:keycloak-services >=0 <26.0.0)

Commands are suggestions: review each one before running it.

Loading voting…