Drupal Umami Analytics allows Cross-Site Scripting (XSS)
CVE-2025-10931GHSA-jxp8-4jw5-5xjc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/umami_analytics 1.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/umami_analytics
- Affected
- < 1.0.1
- Fixed in
- 1.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jxp8-4jw5-5xjc lists affected ranges: Packagist drupal/umami_analytics >=0 <1.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2025-10931: 0.20% estimated exploitation activity in the next 30 days; percentile 10.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Umami Analytics allows Cross-Site Scripting (XSS). This issue affects Umami Analytics: from 0.0.0 before 1.0.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jxp8-4jw5-5xjc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-10931 Advisory: Drupal Umami Analytics allows Cross-Site Scripting (XSS) IDs: CVE-2025-10931, GHSA-jxp8-4jw5-5xjc Record: https://patchnext.com/advisories/cve-2025-10931 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/umami_analytics 1.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/umami_analytics: affected < 1.0.1; fixed in 1.0.1 ## Suggested inspection (read-only) - Packagist drupal/umami_analytics: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/umami_analytics. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jxp8-4jw5-5xjc (GitHub-reviewed advisory GHSA-jxp8-4jw5-5xjc lists affected ranges: Packagist drupal/umami_analytics >=0 <1.0.1) Commands are suggestions: review each one before running it.
Loading voting…