sigstore has insufficient validation of integration timestamp during verification
CVE-2024-55655GHSA-hhfg-fwrw-87w7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sigstore 3.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sigstore
- Affected
- >= 2.0.0, < 3.6.0
- Fixed in
- 3.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hhfg-fwrw-87w7 lists affected ranges: PyPI sigstore >=2.0.0 <3.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hhfg-fwrw-87w7 lists affected ranges: PyPI sigstore >=2.0.0 <3.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2024-55655: 0.25% estimated exploitation activity in the next 30 days; percentile 16.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Versions of sigstore-python newer than 2.0.0 but prior to 3.6.0 perform insufficient validation of the "integration time" present in "v2" and "v3" bundles during the verification flow: the "integration time" is verified if a source of signed time (such as an inclusion promise) is present, but is otherwise trusted if no source of signed time is present. This does not affect "v1" bundles, as the "v1" bundle format always requires an inclusion promise. Details Sigstore uses signed time to support verification of signatures made against short-lived signing keys. Impact The impact and severity of this weakness is low, as Sigstore contains multiple other enforcing components that prevent an attacker who modifies the integration timestamp within a bundle from impersonating a valid signature. In particular, an attacker who modifies the integration timestamp can induce a Denial of Service, but in no different manner than already possible with bundle access (e.g. modifying the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hhfg-fwrw-87w7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-hhfg-fwrw-87w7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-55655 Advisory: sigstore has insufficient validation of integration timestamp during verification IDs: CVE-2024-55655, GHSA-hhfg-fwrw-87w7 Record: https://patchnext.com/advisories/cve-2024-55655 (revision 3, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sigstore 3.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sigstore: affected >= 2.0.0, < 3.6.0; fixed in 3.6.0 ## Suggested inspection (read-only) - `python -m pip show sigstore`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sigstore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hhfg-fwrw-87w7 (OSV record GHSA-hhfg-fwrw-87w7 lists affected ranges: PyPI sigstore >=2.0.0 <3.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hhfg-fwrw-87w7 (GitHub-reviewed advisory GHSA-hhfg-fwrw-87w7 lists affected ranges: PyPI sigstore >=2.0.0 <3.6.0) Commands are suggestions: review each one before running it.
Loading voting…