Skip to content

← Actionable
Medium, CVSS 5.4

sigstore-java has vulnerability with bundle verification

CVE-2024-53267GHSA-q4xm-6fjc-5f6w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dev.sigstore:sigstore-java 1.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2024-53267: 0.10% estimated exploitation activity in the next 30 days; percentile 0.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary sigstore-java has insufficient verification for a situation where a validly-signed but "mismatched" bundle is presented as proof of inclusion into a transparency log Impact This bug impacts clients using any variation of KeylessVerifier.verify() The verifier may accept a bundle with an unrelated log entry, cryptographically verifying everything but fails to ensure the log entry applies to the artifact in question, thereby "verifying" a bundle without any proof the signing event was logged. This allows the creation of a bundle without fulcio certificate and private key combined with an unrelated but time-correct log entry to fake logging of a signing event. A malicious actor using a compromised identity may want to do this to prevent discovery via rekor's log monitors. The signer's identity will still be available to the verifier. The signature on the bundle must still be on the correct artifact for the verifier to pass. sigstore-gradle-plugin and sigstore-maven-plugin are not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q4xm-6fjc-5f6w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-53267

Advisory: sigstore-java has vulnerability with bundle verification
IDs: CVE-2024-53267, GHSA-q4xm-6fjc-5f6w
Record: https://patchnext.com/advisories/cve-2024-53267 (revision 1, source checked 26 Oct 2026, 16:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dev.sigstore:sigstore-java 1.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven dev.sigstore:sigstore-java: affected >= 1.0.0, <= 1.0.0; fixed in 1.1.0

## Suggested inspection (read-only)
- Maven dev.sigstore:sigstore-java: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dev.sigstore:sigstore-java.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q4xm-6fjc-5f6w (GitHub-reviewed advisory GHSA-q4xm-6fjc-5f6w lists affected ranges: Maven dev.sigstore:sigstore-java >=1.0.0 <=1.0.0)

Commands are suggestions: review each one before running it.

Loading voting…