OpenCTI May Bypass Introspection Restriction
CVE-2024-37155GHSA-4mvw-j8r9-xcgc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pycti 6.1.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pycti
- Affected
- < 6.1.9
- Fixed in
- 6.1.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4mvw-j8r9-xcgc lists affected ranges: PyPI pycti >=0 <6.1.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4mvw-j8r9-xcgc lists affected ranges: PyPI pycti >=0 <6.1.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
- EPSS
- CVE-2024-37155: 0.46% estimated exploitation activity in the next 30 days; percentile 40.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The regex validation used to prevent Introspection queries can be bypassed by removing the extra whitespace, carriage return, and line feed characters from the query. Details GraphQL Queries in OpenCTI can be validated using the secureIntrospectionPlugin. Impact Bypassing this restriction allows the attacker to gather a wealth of information about the GraphQL endpoint functionality that can be used to perform actions and/or read data without authorization. These queries can also be weaponized to conduct a Denial of Service (DoS) attack if sent repeatedly.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4mvw-j8r9-xcgc
- Revision 1 · created ·
Published from osv record GHSA-4mvw-j8r9-xcgc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-37155 Advisory: OpenCTI May Bypass Introspection Restriction IDs: CVE-2024-37155, GHSA-4mvw-j8r9-xcgc Record: https://patchnext.com/advisories/cve-2024-37155 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pycti 6.1.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pycti: affected < 6.1.9; fixed in 6.1.9 ## Suggested inspection (read-only) - `python -m pip show pycti`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pycti. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4mvw-j8r9-xcgc (OSV record GHSA-4mvw-j8r9-xcgc lists affected ranges: PyPI pycti >=0 <6.1.9 (fixed)) - Verified: https://github.com/advisories/GHSA-4mvw-j8r9-xcgc (GitHub-reviewed advisory GHSA-4mvw-j8r9-xcgc lists affected ranges: PyPI pycti >=0 <6.1.9) Commands are suggestions: review each one before running it.
Loading voting…