jose4j is vulnerable to DoS via compressed JWE content
CVE-2024-29371GHSA-3677-xxcr-wjqv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.bitbucket.b_c:jose4j 0.9.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.bitbucket.b_c:jose4j
- Affected
- < 0.9.6
- Fixed in
- 0.9.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3677-xxcr-wjqv lists affected ranges: Maven org.bitbucket.b_c:jose4j >=0 <0.9.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2024-29371: 0.26% estimated exploitation activity in the next 30 days; percentile 17.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In jose4j before 0.9.6, an attacker can cause a Denial-of-Service (DoS) condition by crafting a malicious JSON Web Encryption (JWE) token with an exceptionally high compression ratio. When this token is processed by the server, it results in significant memory allocation and processing time during decompression.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3677-xxcr-wjqv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-29371 Advisory: jose4j is vulnerable to DoS via compressed JWE content IDs: CVE-2024-29371, GHSA-3677-xxcr-wjqv Record: https://patchnext.com/advisories/cve-2024-29371 (revision 1, source checked 26 Oct 2026, 16:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.bitbucket.b_c:jose4j 0.9.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.bitbucket.b_c:jose4j: affected < 0.9.6; fixed in 0.9.6 ## Suggested inspection (read-only) - Maven org.bitbucket.b_c:jose4j: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.bitbucket.b_c:jose4j. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3677-xxcr-wjqv (GitHub-reviewed advisory GHSA-3677-xxcr-wjqv lists affected ranges: Maven org.bitbucket.b_c:jose4j >=0 <0.9.6) Commands are suggestions: review each one before running it.
Loading voting…