Skip to content

← Actionable
Medium, CVSS 5.3

Apache Tomcat vulnerable to Generation of Error Message Containing Sensitive Information

CVE-2024-21733GHSA-f4qf-m5gf-8jm8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat.experimental:tomcat-embed-programmatic 9.0.44; org.apache.tomcat:tomcat-coyote 9.0.44, 8.5.64; org.apache.tomcat.embed:tomcat-embed-core 9.0.44, 8.5.64), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-f4qf-m5gf-8jm8 lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=9.0.0-M11 =8.5.7 =8.5.7 =9.0.0-M11 =9.0.43 <9.0.44

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2024-21733: 14.29% estimated exploitation activity in the next 30 days; percentile 96.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f4qf-m5gf-8jm8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-21733

Advisory: Apache Tomcat vulnerable to Generation of Error Message Containing Sensitive Information
IDs: CVE-2024-21733, GHSA-f4qf-m5gf-8jm8
Record: https://patchnext.com/advisories/cve-2024-21733 (revision 1, source checked 26 Oct 2026, 16:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat.experimental:tomcat-embed-programmatic 9.0.44; org.apache.tomcat:tomcat-coyote 9.0.44, 8.5.64; org.apache.tomcat.embed:tomcat-embed-core 9.0.44, 8.5.64. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat.experimental:tomcat-embed-programmatic: affected >= 9.0.43, < 9.0.44; fixed in 9.0.44
- Maven org.apache.tomcat:tomcat-coyote: affected >= 9.0.0-M11, < 9.0.44; >= 8.5.7, < 8.5.64; fixed in 9.0.44, 8.5.64
- Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 8.5.7, < 8.5.64; >= 9.0.0-M11, < 9.0.44; fixed in 9.0.44, 8.5.64

## Suggested inspection (read-only)
- Maven org.apache.tomcat.experimental:tomcat-embed-programmatic: check the installed version with your package manager.
- Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager.
- Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat.experimental:tomcat-embed-programmatic, org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f4qf-m5gf-8jm8 (GitHub-reviewed advisory GHSA-f4qf-m5gf-8jm8 lists affected ranges: Maven org.apache.tomcat:tomcat-coyote >=9.0.0-M11 =8.5.7 =8.5.7 =9.0.0-M11 =9.0.43 <9.0.44)

Commands are suggestions: review each one before running it.

Loading voting…