@fastify/reply-from JSON Content-Type parsing confusion
CVE-2023-51701GHSA-v2v2-hph8-q5xp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/reply-from 9.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 9.6.0
- Fixed in
- 9.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v2v2-hph8-q5xp lists affected ranges: npm @fastify/reply-from >=0 <9.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v2v2-hph8-q5xp lists affected ranges: npm @fastify/reply-from >=0 <9.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-51701: 0.48% estimated exploitation activity in the next 30 days; percentile 41.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The main repo of fastify use fast-content-type-parse to parse request Content-Type, which will trim after split. The fastify-reply-from have not use this repo to unify the parse of Content-Type, which won't trim. As a result, a reverse proxy server built with @fastify/reply-from could misinterpret the incoming body by passing an header ContentType: application/json ; charset=utf-8. This can lead to bypass of security checks. Patches @fastify/reply-from v9.6.0 include the fix. Workarounds There are no known workarounds. References Hackerone Report: https://hackerone.com/reports/2295770.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v2v2-hph8-q5xp
- Revision 1 · created ·
Published from osv record GHSA-v2v2-hph8-q5xp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-51701 Advisory: @fastify/reply-from JSON Content-Type parsing confusion IDs: CVE-2023-51701, GHSA-v2v2-hph8-q5xp Record: https://patchnext.com/advisories/cve-2023-51701 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @fastify/reply-from 9.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @fastify/reply-from: affected < 9.6.0; fixed in 9.6.0 ## Suggested inspection (read-only) - `npm ls @fastify/reply-from --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @fastify/reply-from. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v2v2-hph8-q5xp (OSV record GHSA-v2v2-hph8-q5xp lists affected ranges: npm @fastify/reply-from >=0 <9.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-v2v2-hph8-q5xp (GitHub-reviewed advisory GHSA-v2v2-hph8-q5xp lists affected ranges: npm @fastify/reply-from >=0 <9.6.0) Commands are suggestions: review each one before running it.
Loading voting…