Skip to content

← Actionable
High, CVSS 8.8amended

Local Privilege Escalation in Windows

CVE-2023-49797GHSA-9w2p-rh8c-v9g5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyinstaller 5.13.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-49797: 0.32% estimated exploitation activity in the next 30 days; percentile 25.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A PyInstaller built application, elevated as a privileged process, may be tricked by an unprivileged attacker into deleting files the unprivileged user does not otherwise have access to. A user is affected if all the following are satisfied: The user runs an application containing either matplotlib or win32com. The application is ran as administrator (or at least a user with higher privileges than the attacker). The user's temporary directory is not locked to that specific user (most likely due to TMP/TEMP environment variables pointing to an unprotected, arbitrary, non default location). Either: - The attacker is able to very carefully time the replacement of a temporary file with a symlink. This switch must occur exactly between shutil.rmtree()'s builtin symlink check and the deletion itself - The application was built with Python 3.7.x or earlier which has no protection against Directory Junctions links Patches The vulnerability has been addressed in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9w2p-rh8c-v9g5

  2. Revision 1 · created ·

    Published from osv record GHSA-9w2p-rh8c-v9g5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-49797

Advisory: Local Privilege Escalation in Windows
IDs: CVE-2023-49797, GHSA-9w2p-rh8c-v9g5
Record: https://patchnext.com/advisories/cve-2023-49797 (revision 2, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyinstaller 5.13.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyinstaller: affected < 5.13.1; fixed in 5.13.1

## Suggested inspection (read-only)
- `python -m pip show pyinstaller`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyinstaller.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9w2p-rh8c-v9g5 (OSV record GHSA-9w2p-rh8c-v9g5 lists affected ranges: PyPI pyinstaller >=0 <5.13.1 (fixed))
- Verified: https://github.com/advisories/GHSA-9w2p-rh8c-v9g5 (GitHub-reviewed advisory GHSA-9w2p-rh8c-v9g5 lists affected ranges: PyPI pyinstaller >=0 <5.13.1)

Commands are suggestions: review each one before running it.

Loading voting…