Skip to content

← Actionable
Medium, CVSS 4.3amended

Cleartext Signed Message Signature Spoofing in openpgp

CVE-2023-41037GHSA-ch3c-v47x-4pgp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openpgp 5.10.1, 4.10.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openpgp

    Affected
    < 4.10.11>= 5.0.0, < 5.10.1
    Fixed in
    5.10.1, 4.10.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2023-41037: 0.35% estimated exploitation activity in the next 30 days; percentile 29.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact OpenPGP Cleartext Signed Messages are cryptographically signed messages where the signed text is readable without special tools: These messages typically contain a "Hash: ..." header declaring the hash algorithm used to compute the signature digest. OpenPGP.js up to v5.9.0 ignored any data preceding the "Hash: ..." texts when verifying the signature. As a result, malicious parties could add arbitrary text to a third-party Cleartext Signed Message, to lead the victim to believe that the arbitrary text was signed. A user or application is vulnerable to said attack vector if it verifies the CleartextMessage by only checking the returned verified property, discarding the associated data information, and instead visually trusting the contents of the original message: Since verificationResult.data would always contain the actual signed data, users and apps that check this information are not vulnerable. Similarly, given a CleartextMessage object, retrieving the data using getText()…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-ch3c-v47x-4pgp

  2. Revision 1 · created ·

    Published from osv record GHSA-ch3c-v47x-4pgp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-41037

Advisory: Cleartext Signed Message Signature Spoofing in openpgp
IDs: CVE-2023-41037, GHSA-ch3c-v47x-4pgp
Record: https://patchnext.com/advisories/cve-2023-41037 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openpgp 5.10.1, 4.10.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openpgp: affected < 4.10.11; >= 5.0.0, < 5.10.1; fixed in 5.10.1, 4.10.11

## Suggested inspection (read-only)
- `npm ls openpgp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openpgp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ch3c-v47x-4pgp (OSV record GHSA-ch3c-v47x-4pgp lists affected ranges: npm openpgp >=0 =5.0.0 <5.10.1 (fixed))
- Verified: https://github.com/advisories/GHSA-ch3c-v47x-4pgp (GitHub-reviewed advisory GHSA-ch3c-v47x-4pgp lists affected ranges: npm openpgp >=0 =5.0.0 <5.10.1)

Commands are suggestions: review each one before running it.

Loading voting…