MainWP Dashboard SQL Command Injection vulnerability
CVE-2023-38519GHSA-87fg-9x5w-j3rm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mainwp/mainwp 4.4.3.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mainwp/mainwp
- Affected
- <= 4.4.3.3
- Fixed in
- 4.4.3.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-87fg-9x5w-j3rm lists affected ranges: Packagist mainwp/mainwp >=0 <=4.4.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:L
- EPSS
- CVE-2023-38519: 0.55% estimated exploitation activity in the next 30 days; percentile 46.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in MainWP MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance.This issue affects MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance: from n/a through 4.4.3.3.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-87fg-9x5w-j3rm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-38519 Advisory: MainWP Dashboard SQL Command Injection vulnerability IDs: CVE-2023-38519, GHSA-87fg-9x5w-j3rm Record: https://patchnext.com/advisories/cve-2023-38519 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mainwp/mainwp 4.4.3.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mainwp/mainwp: affected <= 4.4.3.3; fixed in 4.4.3.4 ## Suggested inspection (read-only) - Packagist mainwp/mainwp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mainwp/mainwp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-87fg-9x5w-j3rm (GitHub-reviewed advisory GHSA-87fg-9x5w-j3rm lists affected ranges: Packagist mainwp/mainwp >=0 <=4.4.3.3) Commands are suggestions: review each one before running it.
Loading voting…