Skip to content

← Actionable
Medium, CVSS 6.0amended

Archive spoofing vulnerability in borgbackup

CVE-2023-36811GHSA-8fjr-hghr-4m99

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (borgbackup 1.2.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-36811: 0.11% estimated exploitation activity in the next 30 days; percentile 1.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A flaw in the cryptographic authentication scheme in borgbackup allowed an attacker to fake archives and potentially indirectly cause backup data loss in the repository. The attack requires an attacker to be able to 1. insert files (with no additional headers) into backups 2. gain write access to the repository This vulnerability does not disclose plaintext to the attacker, nor does it affect the authenticity of existing archives. Creating plausible fake archives may be feasible for empty or small archives, but is unlikely for large archives. Affected are all borgbackup releases prior to 1.2.5. Note: CVSS scoring model seemed to badly fit for this case, thus I manually set score to "moderate". Patches The issue has been fixed in borgbackup 1.2.5. But there was a bug in 1.2.5 upgrade instructions, thus 1.2.6 with an important fix in docs and code was released a day afterwards. Additionally to installing the fixed code, users must follow the upgrade procedure as documented in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8fjr-hghr-4m99

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8fjr-hghr-4m99

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-36811

Advisory: Archive spoofing vulnerability in borgbackup
IDs: CVE-2023-36811, GHSA-8fjr-hghr-4m99
Record: https://patchnext.com/advisories/cve-2023-36811 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: borgbackup 1.2.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI borgbackup: affected < 1.2.5; fixed in 1.2.5

## Suggested inspection (read-only)
- `python -m pip show borgbackup`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on borgbackup.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8fjr-hghr-4m99 (OSV record GHSA-8fjr-hghr-4m99 lists affected ranges: PyPI borgbackup >=0 <1.2.5 (fixed))
- Verified: https://github.com/advisories/GHSA-8fjr-hghr-4m99 (GitHub-reviewed advisory GHSA-8fjr-hghr-4m99 lists affected ranges: PyPI borgbackup >=0 <1.2.5)

Commands are suggestions: review each one before running it.

Loading voting…