Skip to content

← Actionable
Medium, CVSS 4.8

Stored XSS in Miniflux when opening a broken image due to unescaped ServerError in proxy handler

CVE-2023-27592GHSA-mqqg-xjhj-wfgw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (miniflux.app/v2 2.0.43), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2023-27592: 0.59% estimated exploitation activity in the next 30 days; percentile 48.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Since v2.0.25, Miniflux will automatically proxy images served over HTTP to prevent mixed content errors. When an outbound request made by the Go HTTP client fails, the html.ServerError is returned unescaped without the expected Content Security Policy header added to valid responses. By creating an RSS feed item with the inline description containing an <img tag with a srcset attribute pointing to an invalid URL like http:a<scriptalert(1)</script, we can coerce the proxy handler into an error condition where the invalid URL is returned unescaped and in full. This results in JavaScript execution on the Miniflux instance as soon as the user is convinced (e.g. by a message in the alt text) to open the broken image. An attacker can execute arbitrary JavaScript in the context of a victim Miniflux user when they open a broken image in a crafted RSS feed. This can be used to perform actions on the Miniflux instance as that user and gain administrative access to the Miniflux instance…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mqqg-xjhj-wfgw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-27592

Advisory: Stored XSS in Miniflux when opening a broken image due to unescaped ServerError in proxy handler
IDs: CVE-2023-27592, GHSA-mqqg-xjhj-wfgw
Record: https://patchnext.com/advisories/cve-2023-27592 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: miniflux.app/v2 2.0.43. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go miniflux.app/v2: affected >= 2.0.25, < 2.0.43; fixed in 2.0.43

## Suggested inspection (read-only)
- Go miniflux.app/v2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on miniflux.app/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mqqg-xjhj-wfgw (GitHub-reviewed advisory GHSA-mqqg-xjhj-wfgw lists affected ranges: Go miniflux.app/v2 >=2.0.25 <2.0.43)

Commands are suggestions: review each one before running it.

Loading voting…