Path Traversal Vulnerability in LESS Parser allows reading of sensitive server files
CVE-2023-27577GHSA-vhm8-wwrf-3gcw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flarum/core 1.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist flarum/core
- Affected
- < 1.7.0
- Fixed in
- 1.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vhm8-wwrf-3gcw lists affected ranges: Packagist flarum/core >=0 <1.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2023-27577: 0.85% estimated exploitation activity in the next 30 days; percentile 58.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If an admin account has already been compromised by an attacker, the LESS parser can be exploited to read sensitive files on the server through the use of path traversal techniques. An attacker can achieve this by providing an absolute path to a sensitive file in the custom LESS setting, which the LESS parser will then read. For example, an attacker could use the following code to read the contents of the /etc/passwd file: Patches The vulnerability has been addressed in version 1.7. Users should upgrade to this version to mitigate the vulnerability. Workarounds Users can mitigate the vulnerability by ensuring that their admin accounts are secured with strong passwords and other best practices for account security. Additionally, users can limit the exposure of sensitive files on the server by implementing appropriate file permissions and access controls.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vhm8-wwrf-3gcw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-27577 Advisory: Path Traversal Vulnerability in `LESS` Parser allows reading of sensitive server files IDs: CVE-2023-27577, GHSA-vhm8-wwrf-3gcw Record: https://patchnext.com/advisories/cve-2023-27577 (revision 1, source checked 26 Oct 2026, 14:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flarum/core 1.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist flarum/core: affected < 1.7.0; fixed in 1.7.0 ## Suggested inspection (read-only) - Packagist flarum/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flarum/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vhm8-wwrf-3gcw (GitHub-reviewed advisory GHSA-vhm8-wwrf-3gcw lists affected ranges: Packagist flarum/core >=0 <1.7.0) Commands are suggestions: review each one before running it.
Loading voting…