Skip to content

← Actionable
Low, CVSS 3.5

Any Flarum user including unactivated can reply in public discussions whose first post was permanently deleted

CVE-2023-22489GHSA-hph3-hv3c-7725

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flarum/core 1.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist flarum/core

    Affected
    >= 1.3.0, < 1.6.3
    Fixed in
    1.6.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2023-22489: 0.58% estimated exploitation activity in the next 30 days; percentile 47.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

If the first post of a discussion is permanently deleted but the discussion stays visible, any actor who can view the discussion is able to create a new reply via the REST API, no matter the reply permission or lock status. This includes users that don't have a validated email. Guests cannot successfully create a reply because the API will fail with a 500 error when the user ID 0 is inserted into the database. This should also be fixed to return the expected 401/403 status. This happens because when the first post of a discussion is permanently deleted, the firstpostid attribute of the discussion becomes null which causes access control to be skipped for all new replies. Flarum automatically makes discussions with zero comments invisible so an additional condition for this vulnerability is that the discussion must have at least one approved reply so that discussions.commentcount is still above zero after the post deletion. Impact This can open the discussion to uncontrolled spam or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hph3-hv3c-7725

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-22489

Advisory: Any Flarum user including unactivated can reply in public discussions whose first post was permanently deleted
IDs: CVE-2023-22489, GHSA-hph3-hv3c-7725
Record: https://patchnext.com/advisories/cve-2023-22489 (revision 1, source checked 26 Oct 2026, 14:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flarum/core 1.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist flarum/core: affected >= 1.3.0, < 1.6.3; fixed in 1.6.3

## Suggested inspection (read-only)
- Packagist flarum/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flarum/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hph3-hv3c-7725 (GitHub-reviewed advisory GHSA-hph3-hv3c-7725 lists affected ranges: Packagist flarum/core >=1.3.0 <1.6.3)

Commands are suggestions: review each one before running it.

Loading voting…