Flarum notifications can leak restricted content
CVE-2023-22488GHSA-8gcg-vwmw-rxj4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flarum/core 1.6.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist flarum/core
- Affected
- < 1.6.3
- Fixed in
- 1.6.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8gcg-vwmw-rxj4 lists affected ranges: Packagist flarum/core >=0 <1.6.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N
- EPSS
- CVE-2023-22488: 0.42% estimated exploitation activity in the next 30 days; percentile 35.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Using the notifications feature, one can read restricted/private content and bypass access checks that would be in place for such content. The notification-sending component does not check that the subject of the notification can be seen by the receiver, and proceeds to send notifications through their different channels. The alerts do not leak data despite this as they are listed based on a visibility check, however, emails are still sent out. This means that, for extensions which restrict access to posts, any actor can bypass the restriction by subscribing to the discussion if the Subscriptions extension is enabled. Impact The attack allows the leaking of some posts in the forum database, including posts awaiting approval, posts in tags the user has no access to if they could subscribe to a discussion before it becomes private, and posts restricted by third-party extensions. Other leaks could also happen for different notification subjects if some features allowed to receive…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8gcg-vwmw-rxj4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-22488 Advisory: Flarum notifications can leak restricted content IDs: CVE-2023-22488, GHSA-8gcg-vwmw-rxj4 Record: https://patchnext.com/advisories/cve-2023-22488 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flarum/core 1.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist flarum/core: affected < 1.6.3; fixed in 1.6.3 ## Suggested inspection (read-only) - Packagist flarum/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flarum/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8gcg-vwmw-rxj4 (GitHub-reviewed advisory GHSA-8gcg-vwmw-rxj4 lists affected ranges: Packagist flarum/core >=0 <1.6.3) Commands are suggestions: review each one before running it.
Loading voting…