Skip to content

← Actionable
High, CVSS 8.7

Keycloak vulnerable to user impersonation via stolen UUID code

CVE-2023-0264GHSA-9g98-5mj6-f9mv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.keycloak:keycloak-services 21.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2023-0264: 1.27% estimated exploitation activity in the next 30 days; percentile 69.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Keycloak's OpenID Connect user authentication was found to incorrectly authenticate requests. An authenticated attacker who could also obtain a certain piece of info from a user request, from a victim within the same realm, could use that data to impersonate the victim and generate new session tokens.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9g98-5mj6-f9mv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-0264

Advisory: Keycloak vulnerable to user impersonation via stolen UUID code
IDs: CVE-2023-0264, GHSA-9g98-5mj6-f9mv
Record: https://patchnext.com/advisories/cve-2023-0264 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.keycloak:keycloak-services 21.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.keycloak:keycloak-services: affected < 21.0.1; fixed in 21.0.1

## Suggested inspection (read-only)
- Maven org.keycloak:keycloak-services: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.keycloak:keycloak-services.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9g98-5mj6-f9mv (GitHub-reviewed advisory GHSA-9g98-5mj6-f9mv lists affected ranges: Maven org.keycloak:keycloak-services >=0 <21.0.1)

Commands are suggestions: review each one before running it.

Loading voting…