Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC
CVE-2022-4361GHSA-3p62-6fjh-3p5h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.keycloak:keycloak-services 21.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.keycloak:keycloak-services
- Affected
- < 21.1.2
- Fixed in
- 21.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3p62-6fjh-3p5h lists affected ranges: Maven org.keycloak:keycloak-services >=0 <21.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2022-4361: 0.69% estimated exploitation activity in the next 30 days; percentile 52.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
AssertionConsumerServiceURL is a Java implementation for SAML Service Providers (org.keycloak.protocol.saml). Affected versions of this package are vulnerable to Cross-site Scripting (XSS). AssertionConsumerServiceURL allows XSS when sending a crafted SAML XML request.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3p62-6fjh-3p5h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-4361 Advisory: Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC IDs: CVE-2022-4361, GHSA-3p62-6fjh-3p5h Record: https://patchnext.com/advisories/cve-2022-4361 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.keycloak:keycloak-services 21.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.keycloak:keycloak-services: affected < 21.1.2; fixed in 21.1.2 ## Suggested inspection (read-only) - Maven org.keycloak:keycloak-services: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.keycloak:keycloak-services. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3p62-6fjh-3p5h (GitHub-reviewed advisory GHSA-3p62-6fjh-3p5h lists affected ranges: Maven org.keycloak:keycloak-services >=0 <21.1.2) Commands are suggestions: review each one before running it.
Loading voting…