Cross site scripting vulnerability with discussion titles
CVE-2022-41938GHSA-7x4w-j98p-854x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flarum/core 1.6.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist flarum/core
- Affected
- >= 1.5.0, < 1.6.2
- Fixed in
- 1.6.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7x4w-j98p-854x lists affected ranges: Packagist flarum/core >=1.5.0 <1.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2022-41938: 0.75% estimated exploitation activity in the next 30 days; percentile 55.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Flarum's page title system allowed for page titles to be converted into HTML DOM nodes when pages were rendered. The change was made after v1.5 and was not noticed. This allowed an attacker to inject malicious HTML markup using a discussion title input, either by creating a new discussion or renaming one. The XSS attack occurs after a visitor opens the relevant discussion page. Impact All communities running Flarum from v1.5.0 to v1.6.1 are impacted. Patches The vulnerability has been fixed and published as flarum/core v1.6.2. All communities running Flarum from v1.5.0 to v1.6.1 have to upgrade as soon as possible to v1.6.2 using: You can then confirm you run the latest version using: Workarounds None For more information For any questions or comments on this vulnerability please visit https://discuss.flarum.org/d/27558. For support questions create a discussion at https://discuss.flarum.org/t/support. A reminder that if you ever become aware of a security issue in Flarum, please…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7x4w-j98p-854x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-41938 Advisory: Cross site scripting vulnerability with discussion titles IDs: CVE-2022-41938, GHSA-7x4w-j98p-854x Record: https://patchnext.com/advisories/cve-2022-41938 (revision 1, source checked 26 Oct 2026, 14:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flarum/core 1.6.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist flarum/core: affected >= 1.5.0, < 1.6.2; fixed in 1.6.2 ## Suggested inspection (read-only) - Packagist flarum/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flarum/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7x4w-j98p-854x (GitHub-reviewed advisory GHSA-7x4w-j98p-854x lists affected ranges: Packagist flarum/core >=1.5.0 <1.6.2) Commands are suggestions: review each one before running it.
Loading voting…