Skip to content

← Actionable
Critical, CVSS 9.8

Variable Tampering within joomla/input class

CVE-2022-23799GHSA-49fj-qp6p-q544

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (joomla/input 2.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist joomla/input

    Affected
    >= 2.0.0, < 2.0.2
    Fixed in
    2.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-23799: 1.23% estimated exploitation activity in the next 30 days; percentile 68.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in Joomla! 4.0.0 through 4.1.0. Under specific circumstances, JInput pollutes method-specific input bags with $REQUEST data.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-49fj-qp6p-q544

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23799

Advisory: Variable Tampering within joomla/input class
IDs: CVE-2022-23799, GHSA-49fj-qp6p-q544
Record: https://patchnext.com/advisories/cve-2022-23799 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: joomla/input 2.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist joomla/input: affected >= 2.0.0, < 2.0.2; fixed in 2.0.2

## Suggested inspection (read-only)
- Packagist joomla/input: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on joomla/input.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-49fj-qp6p-q544 (GitHub-reviewed advisory GHSA-49fj-qp6p-q544 lists affected ranges: Packagist joomla/input >=2.0.0 <2.0.2)

Commands are suggestions: review each one before running it.

Loading voting…