Skip to content

← Actionable
Medium, CVSS 6.3

twill is vulnerable to Cross-Site Request Forgery (CSRF)

CVE-2021-3932GHSA-f99g-pg48-wrfc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (area17/twill 2.5.3, 1.2.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist area17/twill

    Affected
    < 1.2.5>= 2.0.0, < 2.5.3
    Fixed in
    2.5.3, 1.2.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2021-3932: 0.41% estimated exploitation activity in the next 30 days; percentile 34.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

twill is vulnerable to Cross-Site Request Forgery (CSRF).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f99g-pg48-wrfc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-3932

Advisory: twill is vulnerable to Cross-Site Request Forgery (CSRF)
IDs: CVE-2021-3932, GHSA-f99g-pg48-wrfc
Record: https://patchnext.com/advisories/cve-2021-3932 (revision 1, source checked 26 Oct 2026, 14:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: area17/twill 2.5.3, 1.2.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist area17/twill: affected < 1.2.5; >= 2.0.0, < 2.5.3; fixed in 2.5.3, 1.2.5

## Suggested inspection (read-only)
- Packagist area17/twill: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on area17/twill.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f99g-pg48-wrfc (GitHub-reviewed advisory GHSA-f99g-pg48-wrfc lists affected ranges: Packagist area17/twill >=0 =2.0.0 <2.5.3)

Commands are suggestions: review each one before running it.

Loading voting…