Skip to content

← Actionable
High, CVSS 7.5amended

ReDoS in normalize-url

CVE-2021-33502GHSA-px4h-xg32-q955

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (normalize-url 6.0.1, 5.3.1, 4.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm normalize-url

    Affected
    >= 5.0.0, < 5.3.1>= 6.0.0, < 6.0.1>= 4.3.0, < 4.5.1
    Fixed in
    4.5.1, 5.3.1, 6.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2021-33502: 1.70% estimated exploitation activity in the next 30 days; percentile 77.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The normalize-url package before 4.5.1, 5.x before 5.3.1, and 6.x before 6.0.1 for Node.js has a ReDoS (regular expression denial of service) issue because it has exponential performance for data: URLs.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-px4h-xg32-q955

  2. Revision 1 · created ·

    Published from osv record GHSA-px4h-xg32-q955

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-33502

Advisory: ReDoS in normalize-url
IDs: CVE-2021-33502, GHSA-px4h-xg32-q955
Record: https://patchnext.com/advisories/cve-2021-33502 (revision 2, source checked 26 Oct 2026, 12:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: normalize-url 6.0.1, 5.3.1, 4.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm normalize-url: affected >= 5.0.0, < 5.3.1; >= 6.0.0, < 6.0.1; >= 4.3.0, < 4.5.1; fixed in 4.5.1, 5.3.1, 6.0.1

## Suggested inspection (read-only)
- `npm ls normalize-url --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on normalize-url.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-px4h-xg32-q955 (OSV record GHSA-px4h-xg32-q955 lists affected ranges: npm normalize-url >=4.3.0 =5.0.0 =6.0.0 <6.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-px4h-xg32-q955 (GitHub-reviewed advisory GHSA-px4h-xg32-q955 lists affected ranges: npm normalize-url >=5.0.0 =6.0.0 =4.3.0 <4.5.1)

Commands are suggestions: review each one before running it.

Loading voting…