Skip to content

← Actionable
Critical, CVSS 10.0

XSS vulnerability with translator

CVE-2021-32671GHSA-5qjq-69w6-fg57

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flarum/core 1.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist flarum/core

    Affected
    >= 1.0.0, <= 1.0.1
    Fixed in
    1.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2021-32671: 40.00% estimated exploitation activity in the next 30 days; percentile 98.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Flarum's translation system allowed for string inputs to be converted into HTML DOM nodes when rendered. This change was made after v0.1.0-beta.16 (our last beta before v1.0.0) and was not noticed or documented. This allowed for any user to type malicious HTML markup within certain user input fields and have this execute on client browsers. The example which led to the discovery of this vulnerability was in the forum search box. Entering faux-malicious HTML markup, such as <scriptalert('test')</script resulted in an alert box appearing on the forum. This attack could also be modified to perform AJAX requests on behalf of a user, possibly deleting discussions, modifying their settings or profile, or even modifying settings on the Admin panel if the attack was targetted towards a privileged user. Impact All Flarum communities that run flarum v1.0.0 or v1.0.1 are impacted. Patches The vulnerability has been fixed and published as flarum/core v1.0.2. All communities running Flarum v1.0…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5qjq-69w6-fg57

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32671

Advisory: XSS vulnerability with translator
IDs: CVE-2021-32671, GHSA-5qjq-69w6-fg57
Record: https://patchnext.com/advisories/cve-2021-32671 (revision 1, source checked 26 Oct 2026, 14:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flarum/core 1.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist flarum/core: affected >= 1.0.0, <= 1.0.1; fixed in 1.0.2

## Suggested inspection (read-only)
- Packagist flarum/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flarum/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5qjq-69w6-fg57 (GitHub-reviewed advisory GHSA-5qjq-69w6-fg57 lists affected ranges: Packagist flarum/core >=1.0.0 <=1.0.1)

Commands are suggestions: review each one before running it.

Loading voting…