Memory access due to code generation flaw in Cranelift module
CVE-2021-32629GHSA-hpqh-2wqx-7qp5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wasmtime 0.27.0; cranelift-codegen 0.73.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI wasmtime
- Affected
- < 0.27.0
- Fixed in
- 0.27.0
crates.io cranelift-codegen
- Affected
- < 0.73.1
- Fixed in
- 0.73.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hpqh-2wqx-7qp5 lists affected ranges: crates.io cranelift-codegen >=0 =0 <0.27.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hpqh-2wqx-7qp5 lists affected ranges: crates.io cranelift-codegen >=0 =0 <0.27.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2021-32629: 0.46% estimated exploitation activity in the next 30 days; percentile 39.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a bug in 0.73.0 of the Cranelift x64 backend that can create a scenario that could result in a potential sandbox escape in a WebAssembly module. Users of versions 0.73.0 of Cranelift should upgrade to either 0.73.1 or 0.74 to remediate this vulnerability. Users of Cranelift prior to 0.73.0 should update to 0.73.1 or 0.74 if they were not using the old default backend. Description This bug was introduced in the new backend on 2020-09-08 and first included in a release on 2020-09-30, but the new backend was not the default prior to 0.73.0. The recently-released version 0.73.0 with default settings, and prior versions with an explicit build flag to select the new backend, are vulnerable. The bug in question performs a sign-extend instead of a zero-extend on a value loaded from the stack, under a specific set of circumstances. If those circumstances occur, the bug could allow access to memory addresses up to 2GiB before the start of the heap allocated for the WebAssembly module.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hpqh-2wqx-7qp5
- Revision 1 · created ·
Published from osv record GHSA-hpqh-2wqx-7qp5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32629 Advisory: Memory access due to code generation flaw in Cranelift module IDs: CVE-2021-32629, GHSA-hpqh-2wqx-7qp5 Record: https://patchnext.com/advisories/cve-2021-32629 (revision 2, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wasmtime 0.27.0; cranelift-codegen 0.73.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI wasmtime: affected < 0.27.0; fixed in 0.27.0 - crates.io cranelift-codegen: affected < 0.73.1; fixed in 0.73.1 ## Suggested inspection (read-only) - `python -m pip show wasmtime`: prints the installed version. Run with the environment that serves production active. - crates.io cranelift-codegen: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wasmtime, cranelift-codegen. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hpqh-2wqx-7qp5 (OSV record GHSA-hpqh-2wqx-7qp5 lists affected ranges: crates.io cranelift-codegen >=0 =0 <0.27.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hpqh-2wqx-7qp5 (GitHub-reviewed advisory GHSA-hpqh-2wqx-7qp5 lists affected ranges: crates.io cranelift-codegen >=0 =0 <0.27.0) Commands are suggestions: review each one before running it.
Loading voting…