Skip to content

← Actionable
Medium, CVSS 5.5

Mutable reference with immutable provenance in image

CVE-2020-35916GHSA-9wgh-vjj7-7433

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (image 0.23.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io image

    Affected
    < 0.23.12
    Fixed in
    0.23.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2020-35916: 0.39% estimated exploitation activity in the next 30 days; percentile 33.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A mutable reference to a struct was constructed by dereferencing a pointer obtained from slice::asptr. Instead, slice::asmutptr should have been called on the mutable slice argument. The former performs an implicit reborrow as an immutable shared reference which does not allow writing through the derived pointer.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9wgh-vjj7-7433

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-35916

Advisory: Mutable reference with immutable provenance in image
IDs: CVE-2020-35916, GHSA-9wgh-vjj7-7433
Record: https://patchnext.com/advisories/cve-2020-35916 (revision 1, source checked 26 Oct 2026, 15:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: image 0.23.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io image: affected < 0.23.12; fixed in 0.23.12

## Suggested inspection (read-only)
- crates.io image: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on image.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9wgh-vjj7-7433 (GitHub-reviewed advisory GHSA-9wgh-vjj7-7433 lists affected ranges: crates.io image >=0 <0.23.12)

Commands are suggestions: review each one before running it.

Loading voting…